SAAB V4 Forum
SAAB V4 Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Technical
 General Technical
 Intermittent ignition cut out

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format:BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List
  
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)]Big Smile [:D]Cool [8D]Blush [:I]
Tongue [:P]Evil [):]Wink [;)]Clown [:o)]
Black Eye [B)]Eight Ball [8]Frown [:(]Shy [8)]
Shocked [:0]Angry [:(!]Dead [xx(]Sleepy [|)]
Kisses [:X]Approve [^]Disapprove [V]Question [?]

 
Check here to subscribe to this topic.
  

T O P I C    R E V I E W
GeoffCPosted - 22 Mar 2021 : 12:45:30
I'm running out of ideas here so any further suggestions welcome! My Sonett has recently developed an annoying ignition cut out problem. It's just like I've turned the ignition off and then back on again. It doesn't last long but doesn't fill me with confidence to stray too far from home! I have checked coil leads, back of the alternator and the ignition switch but found no loose connections. I have bought new plug leads and that's made no difference either. I have an Acuspark electronic ignition which has been on for several years so am wondering whether it's that as the car doesn't start as instantly as when I first fitted it. So my plan is to buy a new one and hope that solves the problem (I no longer have the points and condenser so can't try that), however if anybody has any other ideas that would help or experienced similar would be great to hear them. I've ruled out fuel as it's instantaneous and the rev counter cuts instantly as well.
15   L A T E S T    R E P L I E S    (Newest First)
GeoffCPosted - 11 Sep 2021 : 17:05:49
Thanks for the tips I'll have a look at where the waters getting in - job for another day. Good news - it has been 10 miles, engine running well pulling strongly and more importantly no ignition cut out!!! Could have been the wire from the ignition switch, half burnt through or the electronic ignition but it appears to have been sorted at last!!!
DerekPosted - 11 Sep 2021 : 14:27:39
eBay.
john-ayrPosted - 10 Sep 2021 : 16:20:19
GeoffC captain Tolley's is a crack cure used by the yacht guys for many years. Probably get it on an on line chandlers.

Regards john.
GeoffCPosted - 10 Sep 2021 : 14:15:06
Not heard of that one I'll have a look thanks!
DerekPosted - 10 Sep 2021 : 12:45:25
Try Captain Tolley's Creeping Crack Cure on your rear window seal. Must be 100% dry with no trapped water. Repeat until it stops soaking in. Keep it off your paint, as it's hard to remove when it dries.
GeoffCPosted - 09 Sep 2021 : 13:34:17
Result!!! Sonett now running, the replacement condenser took ages to arrive but it's sorted the overheating points. The wire from the ignition switch had half melted so have replaced that, set the timing and it started first turn of the key! Pouring with rain here and as the back window leaks I'll have to wait to see if the intermittent fault has gone.
DerekPosted - 03 Sep 2021 : 12:28:22
Follow what Christophe says. With a meter you should be able to see if the LT wire at he dizzy connection is shorted out to the body. The order of the washers, both the metal and nylon ones, are critical here to stop the through bolt from shorting to the body. The shouldered nylon ones should bridge the hole from both sides. Also note that the spring can also short to the casing at this point. Don't do up the retainer nut too tight as this can squash the insulators enough to cause the short.

A general view here scroll down. https://www.912bbs.org/forum/threads/distributor-points-adjuster-screw.55183/
GeoffCPosted - 02 Sep 2021 : 22:49:18
Thanks for the advice re the coil etc. It is a new coil after I tested the original and found a high resistance on the primary circuit. I will check that I haven't blown the new one! Have ordered another condenser as I may have damaged that when it all shorted out. I will also run a new power cable from the ignition switch to the coil as the original wire is showing signs of a melt down - all a but of a mess but I'm running out of ideas so hopefully the new condenser will lessen the current on the points.
christophePosted - 02 Sep 2021 : 17:57:36
I saw many cars with the coil hooked backwards. They ran poorly but did not fried their points. To me, it looks like as if the insulation was defective between the coil and the points. This happens most of the time where the cable ig getting into the distributor. Maybe an insulating washer is missing somewhere. It is time to use your trusty ohmmeter. Check that there is no continuity between the points when they are opened. If your coil is still OK, you should get a 3-4 ohms resistance in the primary circuit and several kilo ohms in the secondary cicuit, depending of what type of coil you got.
EdinburghJoePosted - 02 Sep 2021 : 13:46:21
On the subject of the condenser, there are two things you can do to hurt them:
1) They will break down and become a permanent short if subjected to voltages well in excess of 12v, but you haven't done that
2) If they are connected the wrong way round they will break down instantly, but that's hard on a car given that the metal 'can' always goes to earth (-ve).
EdinburghJoePosted - 02 Sep 2021 : 13:08:06
This is starting to sound to me like the coil might be at fault: maybe the internal insulation on the LT coils have broken down, and now the whole unit is acting as a dead short. This would allow too much current to flow through the points (as you observe) and also mean no spark.

I've never actually tested a coil, but you could maybe try with an in-line HT tester connected to the coil HT output and Earth, and then disconnect the coil -ve from the points and try manually making a brief connection to Earth. That should make an HT pulse.

Another way to test for a short without a voltmeter would be to get a high output bulb (like a headlight bulb), and connect it across the battery, and get an idea of how bright it glows. You could then wire it in series with the coil, and the resistance of the coil should make the light glow less bright. If it stays the same then I'd think it's acting as a short, which could be your problem. When doing this test best to disconnect the coil from the ignition and just use the 'test' wiring.

Hope this is of some use,

Joe

GeoffCPosted - 01 Sep 2021 : 16:29:41
Still no luck. Fitted new points and smelt burning again so switched off ignition quickly. Points VERY hot to the touch burnt my finger! Also noticed power lead to coil had melted so obviously still a short somewhere even though points are connected to -ve side of coil So decided to bypass ignition switch and wiring loom and put a simple 12 volt supply direct to the +ve side of coil. Also changed dizzy cap and rotor arm. Points still getting hot and No spark whilst cranking. So is the condenser burnt out as a result of my earlier mess up so too much current going through the points or am I still missing something obvious. All getting beyond a joke now I'm running out of ideas.
GeoffCPosted - 01 Sep 2021 : 13:33:21
Derek - But the coil has a 12 volt supply to the +ve side so because I stupidly connected the points to that side of the coil, as soon as the points closed it caused a direct short to earth hence the meltdown.

Just got another set of points and screw, from Malbrads super fast delivery service (I don't know how the postal system works so fast for him - when I send anything first class it takes a week!!!). So will have another attempt this afternoon- fingers crossed.
DerekPosted - 01 Sep 2021 : 13:09:19
I'd be interested to know why the "points" melted. With standard ignition the car should run but not optimally if the + and - wires are reversed. This is LT, it shouldn't have the power to melt anything.
GeoffCPosted - 31 Aug 2021 : 22:50:34
John, ditch the Acuspark and try the points, hopefully that will help. Unlikely to be a fuel problem as I believe that car has a bespoke tank. Let us know how you get on.

Snitz Forums 2000
SAAB V4 Forum© 2000-04 Snitz CommunicationsGo To Top Of Page